Subversion Repositories KardasA Overlay

Rev

Rev 108 | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 108 Rev 109
1
# Copyright 1999-2008 Gentoo Foundation
-
 
-
 
1
# Copyright 1999-2011 Gentoo Foundation
2
# Distributed under the terms of the GNU General Public License v2
2
# Distributed under the terms of the GNU General Public License v2
3
# $Header: $
3
# $Header: $
4
4
5
DESCRIPTION="Linux client for programming the Logitech Harmony universal remote"
5
DESCRIPTION="Linux client for programming the Logitech Harmony universal remote"
6
HOMEPAGE="http://www.phildev.net/concordance/"
6
HOMEPAGE="http://www.phildev.net/concordance/"
7
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
7
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
8
8
9
LICENSE="GPL-3"
9
LICENSE="GPL-3"
10
SLOT="0"
10
SLOT="0"
11
KEYWORDS="~x86 ~amd64"
11
KEYWORDS="~x86 ~amd64"
12
IUSE=""
12
IUSE=""
13
13
14
RDEPEND="=dev-libs/libconcord-${PV} \
14
RDEPEND="=dev-libs/libconcord-${PV} \
15
         >=dev-libs/libusb-0.1.12-r1"
15
         >=dev-libs/libusb-0.1.12-r1"
16
DEPEND="${RDEPEND}"
16
DEPEND="${RDEPEND}"
17
17
18
S="${WORKDIR}/${P}/${PN}"
18
S="${WORKDIR}/${P}/${PN}"
19
19
20
src_compile() {
20
src_compile() {
21
	econf || die "configure failed"
21
	econf || die "configure failed"
22
	emake DESTDIR="${D}" || die "make failed"
22
	emake DESTDIR="${D}" || die "make failed"
23
}
23
}
24
24
25
src_install() {
25
src_install() {
26
	emake DESTDIR="${D}" install || die
26
	emake DESTDIR="${D}" install || die
27
	dodoc ../Changelog ../LICENSE README
27
	dodoc ../Changelog ../LICENSE README
28
}
28
}
29
29
30
pkg_postinst() {
30
pkg_postinst() {
31
	einfo "Set up your remote by visiting members.harmonyremote.com."
31
	einfo "Set up your remote by visiting members.harmonyremote.com."
32
	einfo "Click 'Update Remote' to receive Connectivity.EZHex, which"
32
	einfo "Click 'Update Remote' to receive Connectivity.EZHex, which"
33
	einfo "verifies connectivity to the remote.  Run it with:"
33
	einfo "verifies connectivity to the remote.  Run it with:"
34
	echo
34
	echo
35
	einfo "    concordance --connectivity-test Connectivity.EZHex"
35
	einfo "    concordance --connectivity-test Connectivity.EZHex"
36
	echo
36
	echo
37
	einfo "Return to your browser and click to the next screen to receive"
37
	einfo "Return to your browser and click to the next screen to receive"
38
	einfo "Update.EZHex, which contains the new configuration.  Run it with:"
38
	einfo "Update.EZHex, which contains the new configuration.  Run it with:"
39
	echo
39
	echo
40
	einfo "    concordance --write-config Update.EZHex"
40
	einfo "    concordance --write-config Update.EZHex"
41
}
41
}
42
 
42