Subversion Repositories KardasA Overlay

Rev

Rev 138 | Blame | Compare with Previous | Last modification | View Log | RSS feed

# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

EAPI=2

inherit flag-o-matic autotools base

DESCRIPTION="Contains code which is shared across all the components which make up the Citadel system"
HOMEPAGE="http://citadel.org/"
SRC_URI="http://easyinstall.citadel.org/${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND=">=sys-libs/db-4.1.25_p1
        >=dev-libs/libical-0.43
        mail-filter/libsieve
        dev-libs/expat
        net-misc/curl"

DEPEND="${RDEPEND}
        >=sys-devel/autoconf-2.52
        >=sys-devel/libtool-1.4"

src_configure() {
        filter-flags -finline-functions
        replace-flags -O3 -O2
        econf
}


src_prepare() {
        rm conftools/libtool.m4 || die "removal of libtool file failed"
        eautoreconf || die "eautoreconf failed"
}