Subversion Repositories KardasA Overlay

Rev

Blame | Last modification | View Log | RSS feed

# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: j0inty $

inherit subversion

DESCRIPTION="Gfire is an open source plugin for the Pidgin IM client which allows you to connect the Xfire network."
HOMEPAGE="http://gfireproject.org/"
SRC_URI=""

ESVN_REPO_URI="http://my-svn.assembla.com/svn/gfire/trunk/"
ESVN_STORE_DIR="${PORTAGE_ACTUAL_DISTDIR-${DISTDIR}}/svn-src/"

LICENSE="GPLv3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="debug"

RDEPEND="net-im/pidgin"

DEPEND="dev-util/pkgconfig
        ${RDEPEND}"

src_compile(){ 
        econf $(use_enable debug) || die "econf failed"
        emake || die "emake failed"
}

src_install(){
        emake DESTDIR="${D}" install || die "emake install failed"
        dodoc AUTHORS ChangeLog README
}