Subversion Repositories KardasA Overlay

Rev

Rev 165 | Rev 167 | Go to most recent revision | Blame | Compare with Previous | Last modification | View Log | RSS feed

# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 

EAPI="4"

inherit gnome2 eutils

DESCRIPTION="Mint-X Icon themes"
HOMEPAGE="http://packages.linuxmint.com/pool/main/m/mint-x-icons/"
SRC_URI="http://packages.linuxmint.com/pool/main/m/${PN}/${PN}_${PV}.tar.gz
                 branding? ( http://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="branding"

RDEPEND=""

RESTRICT="binchecks strip"

S=${WORKDIR}

src_prepare() {
        if use branding; then
        for i in 16 22 24 32 48; do
                cp "${WORKDIR}"/tango-gentoo-v1.1/${i}x${i}/gentoo.png \
            "${S}"/${PN}/usr/share/icons/Mint-X{,-Dark}/places/${i}x${i}/start-here.png \
                        || die "Copying gentoo logos failed"
        done
        fi
}

src_install() {
        insinto /usr/share/icons
        doins -r mint-x-icons/usr/share/icons/Mint-X{,-Dark}
        insinto /usr/share/pixmaps
        doins -r mint-x-icons/usr/share/pixmaps/pidgin
        dodoc mint-x-icons/debian/changelog  mint-x-icons/debian/copyright
}

pkg_setup() {
        G2CONF="${G2CONF}
                --enable-icon-mapping
                GTK_UPDATE_ICON_CACHE=$(type -P true)"
}